Looking for a new color camera

Hi,

we have an old Leica DM6000 on which we would like to exchange the current color camera (Leica DFC480) with a new color camera and control the system with micro-manager.

The setup is used for brightfield (standard, phase an DIC) as well as fluorescence imaging using various objectives (10x, 20x, 40x and also 100x).

Does somebody have a recommendation for what model we could get for this upgrade?
Thank you for your help!

Olympus and Nikon both make great color cameras, not sure how well they run with micro-manager. I have a Nikon DS-Fi3 on one system (5.9 megapixel) and an Olympus DP22-CU on another (2.8 megapixel), they are both pretty nice without being overly expensive. Olympus came out with 2 new ones, DP28 and DP23, which seem great.

Hi @JamesOrth , thank you for your reply, I did not have the Olympus cameras on my radar!

I checked in the list of supported devices of Micro-Manger, but unfortunately I could not see Olympus cameras clearly listed there.

@nico.stuurman , do you know by chance if there are compatible drivers for the Olympus DP28 or DP23 cameras in MM?

If not, no worries! Other suggestions are of course also always welcome :slight_smile:

Thank you for your help!

Our lab started to use some cameras from a company called Tucsen a brand many people are not familiar with. This one in particular:
http://www.tucsen.com/Home/Product/info/dataid/22.html

When we started with homemade pathology scanners (e.g. H&E), it was low mag, and just used generic industrial machine vision cameras. More recently adding fluorescence and higher mag, better cameras were needed.

Pricing is competitive, and some of their cameras work with micromanager more or less out of the box without coding:
http://www.tucsen.com/Public/upload/download/pdf/Micro-Manager(MM)%20-%20TUCSEN%20cameras.pdf

https://sourceforge.net/p/micro-manager/mailman/message/27114322/

1 Like

Hi @ShawnPatrickCasey,
thank you for your reply!

Tucsen a brand many people are not familiar with. This one in particular:
http://www.tucsen.com/Home/Product/info/dataid/22.html

Indeed I had never heard of Tucsen before and the Dhyana 400DC looks amazing! Thank you for the tip, we will definitely look into this one!

1 Like

We have Hamamatsu, PCO, Andor, Dalsa, Photometrics, etc…a lot of famous high-end camera available in our lab, in-case we need to test for some project. Then we help some others in our department figure out what they really require, prototype and test. But the Tucsen is more affordable, many similar features and no need for additional Camera Link card (some of their example images taken by us). But price/budget you may be able to get a better camera than those from the major brand microscope manufacturers.

Dear Shawn,
I work in the same team as Kai, and we purchased a camera from Tucsen following your advice (Thanks :D)
I installed the camera (Dhyana 400DC) and it is nicely working with Micro-Manager.
However, when I open the images with Fiji, the images are still recognized as RGB in Fluo. So I end up with 3 times more channels…
Did you encounter this, and if yes, what option did I miss in the setup, so I have monochrome images for fluorescent images?
Any suggestions #micro-manager?
Many thanks!

Hi @AlexiaF, welcome to the forum and I apologize for the response you just got there. That does not reflect the tone we’d like to see in this forum.

I don’t have any personal experience with that camera. But often, with cameras that offer a color mode, there will be a setting in the Device/Property Browser that can change the mode of the image you’re collecting. I would have a look there to start with

2 Likes

screen shots would be helpful to debug your problem.

Many thanks @talley , I will double check that! I am not sure what was set by default.

And there will take screenshots for the next post, if I could not sort it out @ShawnPatrickCasey

1 Like

Dealing with color camera images in Micro-Manager is a bit confusing, and is different in different MM versions. In MM 1.4, RGB images are treated as 3 channel images. Your description of 3 channels in Fiji matches that description, so I assume that you are using MM 1.4. It should be possible to convert those into RGB within Fiji. One advantage of that approach is support for >8bit per color RGB, i.e. 12 and 16 bit color images just work.

In 2.0 on the other hand, RGB images will be RGB (and hopefully save as RGB!). The downside is that there is no support for >8bit RGB per color.

4 Likes

Hi all,

I installed MM 2.0.0 gamma (Feb2021).
Below my overall setup for Fluorescence. I do not yet have screenshots from the Device/Property Browser, but could get some on Monday. I think I missed something in the configuration.
Many thanks for your support!

Extra information:

  • I used Fiji 2.1.0/1.53c Java 1.8.0_172 (64 bit)
  • see enclosed a snapshot of the image display in Fiji (Multi-positions acquisition, 2 channels, Zstack)
  • the associated json file as text below.

{
“encoding”: “UTF-8”,
“format”: “Micro-Manager Property Map”,
“major_version”: 2,
“minor_version”: 0,
“map”: {
“AutoscaleIgnoredQuantile”: {
“type”: “DOUBLE”,
“scalar”: 0.0
},
“Autostretch”: {
“type”: “BOOLEAN”,
“scalar”: true
},
“ChannelSettings”: {
“type”: “PROPERTY_MAP”,
“array”: [
{
“Channel”: {
“type”: “STRING”,
“scalar”: “Filter A - DAPI”
},
“ChannelGroup”: {
“type”: “STRING”,
“scalar”: “4- Fluorescence”
},
“Color”: {
“type”: “COLOR”,
“scalar”: {
“ColorSpace”: “sRGB”,
“Components”: [
0.0,
0.0,
0.8
],
“Alpha”: 1.0
}
},
“ComponentSettings”: {
“type”: “PROPERTY_MAP”,
“array”: [
{
“Gamma”: {
“type”: “DOUBLE”,
“scalar”: 1.0
},
“ScalingMax”: {
“type”: “LONG”,
“scalar”: 255
},
“ScalingMin”: {
“type”: “LONG”,
“scalar”: 0
}
},
{
“Gamma”: {
“type”: “DOUBLE”,
“scalar”: 1.0
},
“ScalingMax”: {
“type”: “LONG”,
“scalar”: 9223372036854775807
},
“ScalingMin”: {
“type”: “LONG”,
“scalar”: 0
}
}
]
},
“HistogramBitDepth”: {
“type”: “INTEGER”,
“scalar”: 16
},
“UniformComponentScaling”: {
“type”: “BOOLEAN”,
“scalar”: false
},
“UseCameraBitDepth”: {
“type”: “BOOLEAN”,
“scalar”: true
},
“Visible”: {
“type”: “BOOLEAN”,
“scalar”: true
}
},
{
“Channel”: {
“type”: “STRING”,
“scalar”: “Filter N21 - TRITC”
},
“ChannelGroup”: {
“type”: “STRING”,
“scalar”: “4- Fluorescence”
},
“Color”: {
“type”: “COLOR”,
“scalar”: {
“ColorSpace”: “sRGB”,
“Components”: [
0.8,
0.0,
0.0
],
“Alpha”: 1.0
}
},
“ComponentSettings”: {
“type”: “PROPERTY_MAP”,
“array”: [
{
“Gamma”: {
“type”: “DOUBLE”,
“scalar”: 1.0
},
“ScalingMax”: {
“type”: “LONG”,
“scalar”: 256
},
“ScalingMin”: {
“type”: “LONG”,
“scalar”: 0
}
},
{
“Gamma”: {
“type”: “DOUBLE”,
“scalar”: 1.0
},
“ScalingMax”: {
“type”: “LONG”,
“scalar”: 9223372036854775807
},
“ScalingMin”: {
“type”: “LONG”,
“scalar”: 0
}
}
]
},
“HistogramBitDepth”: {
“type”: “INTEGER”,
“scalar”: 16
},
“UniformComponentScaling”: {
“type”: “BOOLEAN”,
“scalar”: false
},
“UseCameraBitDepth”: {
“type”: “BOOLEAN”,
“scalar”: true
},
“Visible”: {
“type”: “BOOLEAN”,
“scalar”: true
}
},
{
“Channel”: {
“type”: “STRING”,
“scalar”: “Filter I3 - FITC”
},
“ChannelGroup”: {
“type”: “STRING”,
“scalar”: “4- Fluorescence”
},
“Color”: {
“type”: “COLOR”,
“scalar”: {
“ColorSpace”: “sRGB”,
“Components”: [
0.0,
0.8,
0.2
],
“Alpha”: 1.0
}
},
“ComponentSettings”: {
“type”: “PROPERTY_MAP”,
“array”: [
{
“Gamma”: {
“type”: “DOUBLE”,
“scalar”: 1.0
},
“ScalingMax”: {
“type”: “LONG”,
“scalar”: 256
},
“ScalingMin”: {
“type”: “LONG”,
“scalar”: 0
}
},
{
“Gamma”: {
“type”: “DOUBLE”,
“scalar”: 1.0
},
“ScalingMax”: {
“type”: “LONG”,
“scalar”: 9223372036854775807
},
“ScalingMin”: {
“type”: “LONG”,
“scalar”: 0
}
}
]
},
“HistogramBitDepth”: {
“type”: “INTEGER”,
“scalar”: 8
},
“UniformComponentScaling”: {
“type”: “BOOLEAN”,
“scalar”: false
},
“UseCameraBitDepth”: {
“type”: “BOOLEAN”,
“scalar”: true
},
“Visible”: {
“type”: “BOOLEAN”,
“scalar”: true
}
},
{
“Channel”: {
“type”: “STRING”,
“scalar”: “Filter N21 - TRITC”
},
“ChannelGroup”: {
“type”: “STRING”,
“scalar”: “4- Fluorescence”
},
“Color”: {
“type”: “COLOR”,
“scalar”: {
“ColorSpace”: “sRGB”,
“Components”: [
0.8,
0.0,
0.0
],
“Alpha”: 1.0
}
},
“ComponentSettings”: {
“type”: “PROPERTY_MAP”,
“array”: [
{
“Gamma”: {
“type”: “DOUBLE”,
“scalar”: 1.0
},
“ScalingMax”: {
“type”: “LONG”,
“scalar”: 99
},
“ScalingMin”: {
“type”: “LONG”,
“scalar”: 0
}
},
{
“Gamma”: {
“type”: “DOUBLE”,
“scalar”: 1.0
},
“ScalingMax”: {
“type”: “LONG”,
“scalar”: 9223372036854775807
},
“ScalingMin”: {
“type”: “LONG”,
“scalar”: 0
}
}
]
},
“HistogramBitDepth”: {
“type”: “INTEGER”,
“scalar”: 16
},
“UniformComponentScaling”: {
“type”: “BOOLEAN”,
“scalar”: false
},
“UseCameraBitDepth”: {
“type”: “BOOLEAN”,
“scalar”: true
},
“Visible”: {
“type”: “BOOLEAN”,
“scalar”: true
}
}
]
},
“ColorMode”: {
“type”: “STRING”,
“scalar”: “COMPOSITE”
},
“PlaybackFPS”: {
“type”: “DOUBLE”,
“scalar”: 10.0
},
“ROIAutoscale”: {
“type”: “BOOLEAN”,
“scalar”: true
},
“UniformChannelScaling”: {
“type”: “BOOLEAN”,
“scalar”: false
},
“ZoomRatio”: {
“type”: “DOUBLE”,
“scalar”: 0.3333333333333333
}
}
}

It is a bit difficult to understand what is going on from the file Micro-Manager uses to store displaysettings. That file lists 4 channels, but I do believe that your data had only two channels.

Is it possible to post the complete MIcro-Manager data set?

It be easier to start experimenting with very simple things. Take a single RGB image, have Micro-Manager save it as either single Tiff or Multipage (stack) Tiff and open in Fiji. B.t.w. there are multiple ways of opening data in Fiji (especially, with and without Bioformats). See when Fiji opens it as a single RGB image, and when it opens it as an RGB image.

B.t.w. Micro-Manager also has an “send to ImageJ” option in the viewer under the gear icon. That should also appear as a real RGB image (but I am not sure what ImageJ does in general with multi-channel RGB images, come to think about it, that could be the real underlying problem, i.e. it is possible that ImageJ - unlike Micro-Manager - does not know how to work with multi-channel RGB. Going out of my league here, so please take this only as an hypothesis).

2 Likes

Many thanks @nico.stuurman
Indeed, I am always using the BioFormats importer by default.
I tested with and without the BioFormats importer, in our Fiji version 2.1.0 and in the version coming with MM (ImageJ 1.51s).
As soon as I do not use the BioFormats importer, the channels are recognized properly, meaning 1 RGB image per channel instead of single R / G/ B images per channel.
Many thanks for your help and support!

1 Like